Kartra System Outage
Incident Report for Kartra
Resolved
This incident has been resolved. Kartra is back up and running as expected. If you experience any further downtime, please reach out to us at support@genesisdigital.co.
Posted May 06, 2023 - 13:50 UTC
Investigating
Our development team is investigating the root cause of the issue, and we are working diligently to bring Kartra back up as soon as possible.
Posted May 06, 2023 - 12:39 UTC
This incident affected: APP (Kartra App).