Kartra Service Disruption
Incident Report for Kartra
Resolved
Everything seems to be operational.
Posted Feb 29, 2024 - 20:57 UTC
Investigating
We are currently experiencing a service disruption.

Our Development team is working to identify the root cause and implement a solution. Users may experience trouble uploading or playing videos/media.

We will send an additional update as soon as we know more.
Posted Feb 29, 2024 - 18:59 UTC
This incident affected: APP (Kartra App).